Back to overview

Update to recent downtime

May 02 at 10:40am BST

Resolved
May 02 at 10:40am BST

DNS errors caused a large amount of apparent downtime throughout the last week. We've successfully resolved these issues and apologies for any disruption caused.